您的位置:首页 > 其它

Be the Winner HDU - 2509

2018-03-08 20:32 369 查看
Be the Winner

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4387 Accepted Submission(s): 2436

Problem Description

Let’s consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.

For example “@@@” can be turned into “@@” or “@” or “@ @”(two piles). two people get apples one after another and the one who takes the last is

the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).

Input

You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.

Output

If a winning strategies can be found, print a single line with “Yes”, otherwise print “No”.

Sample Input

2

2 2

1

3

Sample Output

No

Yes

Source

ECJTU 2008 Autumn Contest

和上一篇基本一样,代码基本没改。。。。。

题目: John HDU - 1907

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
#define ll long long

using namespace std;

const int MAXN=1000000;

int main(){
int g, c, n, T;
while(scanf("%d",&n) != EOF) {
int a, sum = 0;
g = c = 0;
for(int i = 0; i < n; i++)
{
scanf("%d",&a);
sum ^= a;
if(a == 1) g ++;
else c ++;
}
if((sum == 0&& c >= 2) || ((sum != 0)&&(c == 0)&&(g %2 != 0)))
puts("No");
else
puts("Yes");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: