您的位置:首页 > 其它

HDU 2601 An easy problem(数学)

2018-03-08 19:44 363 查看

An easy problem

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10301 Accepted Submission(s): 2604

Problem Description

When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :



Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.

Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

Input

The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 1010).

Output

For each case, output the number of ways in one line.

Sample Input

2

1

3

Sample Output

0

1

Author

Teddy

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest

题意就不多说了,所以下解题方法:

i*j+i+j=n

可得: i*(j+1)+j=n –> i*(j+1)+j+1=n+1 —-> (i+1)*(j+1)=n+1

把 i+1 ,j+1, N+1分别看成三个数,这样就简单了。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;

int main()
{
long long int n,m,num;
int t;
scanf("%d",&t);
while(t--)
{
scanf("%lld",&n);
n++;
m=sqrt(n);
num=0;
for(long long int i=2;i<=m;i++)
{
if(n%i==0)
num++;
}
printf("%lld\n",num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: