您的位置:首页 > 其它

POJ 1046 Color Me Less

2018-03-07 21:27 459 查看
Color Me Less[align=center]
Time Limit: 1000MS
 
Memory Limit: 10000K
Total Submissions: 35111
 
Accepted: 17049
[/align]Description
A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform just such a mapping in a standard twenty-four bit RGB color space. The input consists of a target set of sixteen RGB color values, and a collection of arbitrary RGB colors to be mapped to their closest color in the target set. For our purposes, an RGB color is defined as an ordered triple (R,G,B) where each value of the triple is an integer from 0 to 255. The distance between two colors is defined as the Euclidean distance between two three-dimensional points. That is, given two colors (R1,G1,B1) and (R2,G2,B2), their distance D is given by the equation  
Input
The input is a list of RGB colors, one color per line, specified as three integers from 0 to 255 delimited by a single space. The first sixteen colors form the target set of colors to which the remaining colors will be mapped. The input is terminated by a line containing three -1 values.
Output
For each color to be mapped, output the color and its nearest color from the target set. 

If there are more than one color with the same smallest distance, please output the color given first in the color set.
Sample Input
0 0 0
255 255 255
0 0 1
1 1 1
128 0 0
0 128 0
128 128 0
0 0 128
126 168 9
35 86 34
133 41 193
128 0 128
0 128 128
128 128 128
255 0 0
0 1 0
0 0 0
255 255 255
253 254 255
77 79 134
81 218 0
-1 -1 -1
Sample Output
(0,0,0) maps to (0,0,0)
(255,255,255) maps to (255,255,255)
(253,254,255) maps to (255,255,255)
(77,79,134) maps to (128,128,128)
(81,218,0) maps to (126,168,9)
Source
Greater New York 2001
 
 
解题思路:
首先将前16组数字分别将三个数字按顺序存在三个数组中,再进行计算。
虽然是水题,但是要注意在输完16组数据后,每次要将位置初始化为0.
以下为我的AC代码。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

int main()
{
int arr1[20], arr2[20], arr3[20], jl_x, jl_y, jl_z, x, y, z;
double mini;
for(int i = 0; i < 16; i++)
{
scanf("%d %d %d", &arr1[i], &arr2[i], &arr3[i]);
}
while(scanf("%d %d %d", &x, &y, &z) != EOF)
{
jl_x = 0, jl_y = 0, jl_z = 0;
if(x == -1 && y == -1 && z == -1) break;
mini = sqrt(pow(x-arr1[0], 2) + pow(y-arr2[0], 2) + pow(z-arr3[0], 2));
for(int i = 1; i < 16; i++)
{
if(mini > sqrt(pow(x-arr1[i], 2) + pow(y-arr2[i], 2) + pow(z-arr3[i], 2)))
{
mini = sqrt(pow(x-arr1[i], 2) + pow(y-arr2[i], 2) + pow(z-arr3[i], 2));
jl_x = jl_y = jl_z = i;
}
}
printf("(%d,%d,%d) maps to (%d,%d,%d)\n", x, y, z, arr1[jl_x], arr2[jl_y], arr3[jl_z]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: