您的位置:首页 > 其它

最小生成树- Jungle Roads POJ - 1251

2018-03-07 20:18 363 查看
题目大意:给你N个点,然后有N-1行,每行先输入起点,然后输入和他有边(即可以直接到达)的点有k个,然后输入这k个点的和到他们的花费。问使这些这些点都连通的最小花费是多少?特别提醒:正常的最小生成树,只需处理好空格和换行,最该注意,最后那个输入0,直接跳出循环的。


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input The input consists of one to 100 data sets, fo
4000
llowed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
Output The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
Sample Input
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
Sample Output
216
30


下面是AC代码,有不足之处希望大佬们及时指出:
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int n , m , f[1005] ;
struct Edge{
int u , v , w ;
}edge[1005];

void init()
{
for(int i = 0 ; i <= n ; i ++)
f[i] = i ;
}

bool cmp(Edge x , Edge y)
{
return x.w < y.w ;
}

int find(int x)
{
if(x !=  f[x])
f[x] = find(f[x]);
return f[x] ;
}

int kruskal()
{
int ans = 0 ,cnt = 0 ;
init();
sort(edge , edge + m , cmp);
for(int i = 0 ; i < m ; i ++)
{
int u = edge[i].u , v = edge[i].v , w= edge[i].w ;
int r1 = find(u) , r2 = find(v) ;
if(r1 != r2)
{
f[r1] = r2 ;
ans += w ;
cnt ++ ;
if(cnt == n - 1 )
break;
}
}
return ans;
}

int main()
{
while(scanf("%d",&n))
{
if(n == 0 )
break;
m = 0 ;
for(int i = 1 ; i < n ; i ++)
{
char u , v ;
int w , k ;
scanf(" %c %d",&u , &k);
while(k--)
{
scanf(" %c %d",&v , &w);
edge[m].u = u - 'A' ;
edge[m].v = v - 'A' ;
edge[m].w = w ;
m++;
}
}
printf("%d\n",kruskal());
}
return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: