您的位置:首页 > 其它

POJ 2774 Long Long Message

2018-03-07 19:40 267 查看
The little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days: his mother is getting ill. Being worried about spending so much on railway tickets (Byterland is such a big country, and he has to spend 16 shours on train to his hometown), he decided only to send SMS with his mother.

The little cat lives in an unrich family, so he frequently
comes to the mobile service center, to check how much money he has spent
on SMS. Yesterday, the computer of service center was broken, and
printed two very long messages. The brilliant little cat soon found out:

1. All characters in messages are lowercase Latin letters, without punctuations and spaces.

2. All SMS has been appended to each other – (i+1)-th SMS
comes directly after the i-th one – that is why those two messages are
quite long.

3. His own SMS has been appended together, but possibly a
great many redundancy characters appear leftwards and rightwards due to
the broken computer.

E.g: if his SMS is “motheriloveyou”, either long message
printed by that machine, would possibly be one of “hahamotheriloveyou”,
“motheriloveyoureally”, “motheriloveyouornot”, “bbbmotheriloveyouaaa”,
etc.

4. For these broken issues, the little cat has printed his
original text twice (so there appears two very long messages). Even
though the original text remains the same in two printed messages, the
redundancy characters on both sides would be possibly different.

You are given those two very long messages, and you have to
output the length of the longest possible original text written by the
little cat.

Background:

The SMS in Byterland mobile service are charging in
dollars-per-byte. That is why the little cat is worrying about how long
could the longest original text be.

Why ask you to write a program? There are four resions:

1. The little cat is so busy these days with physics lessons;

2. The little cat wants to keep what he said to his mother seceret;

3. POJ is such a great Online Judge;

4. The little cat wants to earn some money from POJ, and try to persuade his mother to see the doctor :(

Input

Two strings with lowercase letters on two of the input lines
individually. Number of characters in each one will never exceed 100000.

Output

A single line with a single integer number – what is the maximum length of the original text written by the little cat.

Sample Input

yeshowmuchiloveyoumydearmotherreallyicannotbelieveit
yeaphowmuchiloveyoumydearmother

Sample Output

27
把字符串拼起来
然后求后缀数组
答案为最大的height,height[i]对应的sa[i]和sa[i-1]位于不同串

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int c[300001],x[300001],y[300001],SA[300001],rank[300001],h[300001],n,m,s[300001],len,ans;
char ch[300001];
void radix_sort()
{int i;
for (i=0;i<=m;i++)
c[i]=0;
for (i=1;i<=n;i++)
c[x[y[i]]]++;
for (i=2;i<=m;i++)
c[i]+=c[i-1];
for (i=n;i>=1;i--)
SA[c[x[y[i]]]--]=y[i];
}
void build_SA()
{int i,j,k,p;
for (i=1;i<=n;i++)
x[i]=s[i],y[i]=i;
m=100000;
radix_sort();
for (k=1;k<=n;k<<=1)
{
p=0;
for (i=n-k+1;i<=n;i++)
y[++p]=i;
for (i=1;i<=n;i++)
if (SA[i]>k) y[++p]=SA[i]-k;
radix_sort();
p=1;swap(x,y);
x[SA[1]]=1;
for (i=2;i<=n;i++)
x[SA[i]]=((y[SA[i]]==y[SA[i-1]])&&(y[SA[i]+k]==y[SA[i-1]+k]))?p:++p;
if (p>=n) break;
m=p;
}
for (i=1;i<=n;i++)
rank[SA[i]]=i;
int L=0;
for (i=1;i<=n;i++)
{
if (L>0) L--;
j=SA[rank[i]-1];
while (i+L<=n&&j+L<=n&&(s[j+L]==s[i+L])) L++;
h[rank[i]]=L;
}
}
int main()
{int i,l;
cin>>ch;
len=strlen(ch);
for (i=1;i<=len;i++)
{
s[++n]=(int){ch[i-1]};
}
s[++n]=10000;
cin>>ch;
l=strlen(ch);
for (i=1;i<=l;i++)
{
s[++n]=(int){ch[i-1]};
}
build_SA();
for (i=2;i<=n;i++)
if ((SA[i]<=len)^(SA[i-1]<=len)) ans=max(ans,h[i]);
cout<<ans;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: