您的位置:首页 > 其它

(pat)A1034. Head of a Gang

2018-03-07 10:30 351 查看
One way that the police finds the head of a gang is to check people’s phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A “Gang” is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threshold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59

AAA BBB 10

BBB AAA 20

AAA CCC 40

DDD EEE 5

EEE DDD 70

FFF GGG 30

GGG HHH 20

HHH FFF 10

Sample Output 1:

2

AAA 3

GGG 3

Sample Input 2:

8 70

AAA BBB 10

BBB AAA 20

AAA CCC 40

DDD EEE 5

EEE DDD 70

FFF GGG 30

GGG HHH 20

HHH FFF 10

Sample Output 2:

0

评价:这题有一点点意思,本质上求联通分量,但是有一点要注的是,需要求一个联通分量的边权之和,而且还有重边。那么直接的一个思路是需要给边进行编号,然后记录在遍历时有哪些边没有访问过。一开始我就是这样做的,但是实现复杂。后来我想到的是把边权转移到点权,那么我们把一个联通分量里的点权全部相加,那么所得值就和实际值的两倍,因为每条边被算了两次。那么实现起来就容易得多,而且不需要额外定义边的结构。

此外关于字符串和点的映射。显然需要的是字符串到点的映射,这个用map就好了。但是输出的时候需要输出字符串,所以又需要点到字符串的映射,这个用数组就行了。

代码:

#include<iostream>
#include<cstdio>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;

vector<int> graph[2005];
int val[2005];
string ind[2005];
int num=0;
map<string,int> mapp;
void addEdge(string s1,string s2,int w)
{
int x1,x2;
if(mapp.find(s1)==mapp.end())
{
ind[num]=s1;
mapp[s1]=num;
x1=num++;
}
else
x1=mapp[s1];
if(mapp.find(s2)==mapp.end())
{
ind[num]=s2;
mapp[s2]=num;
x2=num++;
}
else
x2=mapp[s2];
graph[x1].push_back(x2);
graph[x2].push_back(x1);
val[x1]+=w;
val[x2]+=w;
}
bool vis[2005];
int ans;
int countt;
int total;
void dfs(int v)
{
countt++;
total+=val[v];
if(val[v]>val[ans])
ans=v;
for(int i=0;i<graph[v].size();i++)
{
int u=graph[v][i];
if(vis[u])
continue;
vis[u]=true;
dfs(u);
}
}
struct T
{
int ind;
int num;

} ans2[1005];//答案存放,因为需要字典序输出
int l=0;
bool cmp(T t1,T t2)
{
return ind[t1.ind]<ind[t2.ind];
}
int n,k;
int main()
{
scanf("%d%d",&n,&k);
string str1,str2;
int x;
while(n--)
{
cin>>str1>>str2>>x;
addEdge(str1,str2,x);
}
for(int i=0;i<num;i++)
{
if(vis[i])
continue;
ans=i;
countt=0;
total=0;
vis[i]=true;
dfs(i);
if(total/2>k&&countt>2)
{
T temp;
temp.ind=ans;
temp.num=countt;
ans2[l++]=temp;
}
}
printf("%d\n",l);
if(l>0)
sort(ans2,ans2+l,cmp);
for(int i=0;i<l;i++)
cout<<ind[ans2[i].ind]<<" "<<ans2[i].num<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: