您的位置:首页 > 其它

PAT甲级 1139. First Contact (30)

2018-03-07 09:29 471 查看
1139. First Contact (30)
Sample Input:
Sample Output:
题意
分析
代码

1139. First Contact (30)

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B — quite a long shot, isn’t it? Girls would do analogously.
Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N <= 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.
After the relations, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.
Output Specification:
For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.
If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.
The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

题意

给出n个人m对朋友关系,给出k个询问,每次问两个人A,B,问存在的所有C和D,要求A的同性朋友C,B的同性朋友D,且C,D也是朋友

分析

暴力匹配即可,遍历A的同性朋友C和B的同性朋友D,判断C,D是否认识即可
大问题没有…只有细节问题,那就是0和-0是有区别的,6分

代码

#include <bits/stdc++.h>
using namespace std;

struct XX{
int x,y;
};
vector<XX>ans;
vector<int>f[10000];
int sex[10000]={0}; //0man 1woman

bool cmp(const XX&x,const XX&y)
{
if (x.x!=y.x) return x.x<y.x;
return x.y<y.y;
}

int main()
{
int n,m;scanf("%d%d",&n,&m);
for (int i=0;i<m;i++)
{
char s[20];
int now=0;
int j=0;
int flag = 0;
scanf("%s",s);
if (s[0]=='-') flag = 1,j++;
for (;s[j]!='\0';j++) now=now*10+s[j]-48;
int x=now;
sex[x]=flag;
now=0;
j=0;
flag = 0;
scanf("%s",s);
if (s[0]=='-') flag = 1,j++;
for (;s[j]!='\0';j++) now=now*10+s[j]-48;
int y=now;
sex[y]=flag;
f[x].push_back(y);
f[y].push_back(x);
}
scanf("%d",&m);
while (m--)
{
char s[20];
int now=0;
int j=0;
int flag = 0;
scanf("%s",s);
if (s[0]=='-') flag = 1,j++;
for (;s[j]!='\0';j++) now=now*10+s[j]-48;
int x=now;
int sx=flag;
now=0;
j=0;
flag = 0;
scanf("%s",s);
if (s[0]=='-') flag = 1,j++;
for (;s[j]!='\0';j++) now=now*10+s[j]-48;
int y=now;
int sy=flag;
ans.clear();
for (int i=0;i<f[x].size();i++)
if (sex[f[x][i]] == sx && f[x][i]!=y)
for (int i1=0;i1<f[y].size();i1++)
if (sex[f[y][i1]] == sy && f[y][i1]!=x)
{
int f1=f[x][i];
int f2=f[y][i1];
for (int j=0;j<f[f1].size();j++)
if (f[f1][j] == f2)
{
ans.push_back(XX{f1,f2});
break;
}
}
printf("%d\n",ans.size());
sort(ans.begin(),ans.end(),cmp);
for (int i=0;i<ans.size();i++)
{
//if (i &&ans[i].x == ans[i-1].x && ans[i].y==ans[i-1].y) continue;
printf("%04d %04d\n",ans[i].x,ans[i].y);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: