您的位置:首页 > 产品设计 > UI/UE

HDU 1159 Common Subsequence(LCS)

2018-03-06 19:20 363 查看
题目:

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = %lt;z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input:

abcfbc abfcab

programming contest

abcd mnp

Sample Output:

4

2

0

最长公共子序列问题(LCS, Longest Common Subsequence)

dp[i][j]:str11~str2i和str21~str2i对应的LCS长度

因此,str11~str2i和str21~str2i对应的公共子列有三种情况:

(1) :当str1i=str2i时,在str11~str2i和str21~str2i的公共子列末尾追加上str1i(或者str2i)
(2):str11~str2i-1和str21~str2i的公共子列
(3):str11~str2i和str21~str2i-1的公共子列


所以递推式:

dp[i+1][j+1]=max(dp[i][j]+1,dp[i][j+1],dp[i+1][j])(str1i+1=str2i+1)
dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j])(其他)


AC代码:

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <iomanip>
#include <cctype>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <cstdlib>
#include <sstream>
#include <set>
#include <map>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
typedef long long ll;
typedef pair<int, int> P;
const int INF = 0x3f3f3f3f;
const int maxn = 510;
const double eps = 1e-5;
const double e = 2.718281828459;

string str1, str2;
int dp[maxn][maxn];

void LCS() {
int lenA = str1.length(), lenB = str2.length();
for (int i = 0; i < lenA; ++i) {
for (int j = 0; j < lenB; ++j) {
if (str1[i] == str2[j]) {
dp[i + 1][j + 1] = dp[i][j] + 1;
}
else {
dp[i + 1][j + 1] = max(dp[i][j + 1], dp[i + 1][j]);
}
}
}
cout << dp[lenA][lenB] << endl;
}

int main() {
ios::sync_with_stdio(0);
cin.tie(0);
while (cin >> str1 >> str2) {
mem(dp, 0);
LCS();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划