您的位置:首页 > 其它

1120. Friend Numbers (20)

2018-03-06 15:35 309 查看
1120. Friend Numbers (20)

时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B

判题程序 Standard 作者 CHEN, Yue

Two integers are called “friend numbers” if they share the same sum of their digits, and the sum is their “friend ID”. For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID’s among them. Note: a number is considered a friend of itself.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.

Output Specification:

For each case, print in the first line the number of different frind ID’s among the given integers. Then in the second line, output the friend ID’s in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8

123 899 51 998 27 33 36 12

Sample Output:

4

3 6 9 26

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <cstring>
#include <iomanip>
#include <vector>
#include <string>
#include <cfloat>
#include <queue>
#include <map>
#include <set>

using namespace std;
const int MaxN = 10010;
bool isFriend[MaxN] = { 0 };
set<int> fridid;

int main()
{
#ifdef _DEBUG
freopen("data.txt", "r+", stdin);
#endif // _DEBUG
std::ios::sync_with_stdio(false);

int N, num;
cin >> N;
for (int i = 0; i < N; ++i)
{
cin >> num;
int frid = 0;
while (num)
{
frid += num % 10;
num /= 10;
}

if (!isFriend[frid])
{
isFriend[frid] = true;
fridid.insert(frid);
}
}

cout << fridid.size() << endl;
for (auto it = fridid.begin(); it != fridid.end(); )
{
cout << *it;
++it;
if (it != fridid.end())cout << " ";
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat甲级 1120