您的位置:首页 > 其它

PAT 1023. Have Fun with Numbers (20)

2018-03-05 16:50 489 查看
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different
permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.
Sample Input:
1234567899

Sample Output:
Yes
2469135798


思路:这题比较简单,列竖式计算即可

#include <iostream>
#include <string>
#include <vector>
#include <stack>
#include <algorithm>
using namespace std;
int main()
{
string num;
vector<int> v;
vector<int> v1;
stack<int> s;
cin>>num;
for(int i = 0; i < num.size(); i++)
{
v.push_back(num[i] - '0');
}
int mod = 0;
for(int i = v.size() - 1; i >= 0; i--)
{
s.push((v[i] * 2 + mod) % 10);
mod = (v[i] * 2 + mod) / 10;
}
if(mod != 0)
s.push(mod);
string res;
while(!s.empty())
{
res = res + static_cast<char>(s.top() + '0');
v1.push_back(s.top());
s.pop();
}
sort(v.begin(),v.end());
sort(v1.begin(),v1.end());
bool flag = true;
if(v.size() != v1.size())
flag = false;
for(int i = 0; i < v.size(); i++)
if(v[i] != v1[i])
{
flag = false;
break;
}
if(flag)
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
cout<
4000
;<res<<endl;
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT