您的位置:首页 > 其它

PAT A1109. Group Photo (25)

2018-03-04 15:11 375 查看
Group Photo (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;

All the people in the rear row must be no shorter than anyone standing in the front rows;

In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);

In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (<=10000), the total number of people, and K (<=10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:

For each case, print the formation – that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:

10 3

Tom 188

Mike 170

Eva 168

Tim 160

Joe 190

Ann 168

Bob 175

Nick 186

Amy 160

John 159

Sample Output:

Bob Tom Joe Nick

Ann Mike Eva

Tim Amy John

//这是一道典型的排版题,只要的左端,右端和中点的位置搞清楚就很容易了。搞不清楚的话,+1,-1随便试试,关键是别乱。另外,根据输出情况和排数不超过10的暗示,应该想到用二维数组存储答案。

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=10010;

struct Student{
char name[12];
int h;
}stu[maxn];
int ans[11][maxn];

int num[maxn];
int leftman[maxn];

int n,k;
bool cmp(Student a,Student b){
if(a.h!=b.h)return a.h>b.h;
else return strcmp(a.name,b.name)<0;
}
int main(){
scanf("%d %d",&n,&k);
for(int i=0;i<n;i++){
scanf("%s %d",stu[i].name,&stu[i].h);
}
sort(stu,stu+n,cmp);
for(int i=0;i<k-1;i++){
num[i]=n/k;
}
leftman[k]=n-1;
for(int i=k-1;i>=0;i--){
leftman[i]=leftman[i+1]-num[i];
}
num[k-1]=n-(n/k)*(k-1);
int idx=0;
for(int i=k-1;i>=0;i--){
int l=leftman[i];
int r=leftman[i]+num[i]-1;
int mid=(r-l+1)/2;
int d=0;
for(int j=0;j<num[i];j++){
ans[i][mid+d]=idx++;
if(j%2==0)d++;
d*=-1;
}
}
for(int i=k-1;i>=0;i--){
for(int j=0;j<num[i];j++){
printf("%s",stu[ans[i][j]].name);
if(j<num[i]-1)printf(" ");
else printf("\n");
}
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: