您的位置:首页 > 其它

PAT (Advanced Level)1024. Palindromic Number (25) string的reverse() assign begin end rbegin rend

2018-03-04 14:53 381 查看
与1023题类型一致
用字符串实现大数相加
reverse()函数
题目链接

1024. Palindromic Number (25)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.Input Specification:Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.Output Specification:For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3

//1024. Palindromic Number(25)

#include <iostream>
#include <algorithm>
#include <string>
using namespace std;

string add(string s1, string s2) {
string result = "";
int len1 = s1.length();
int len2 = s2.length();
int carry = 0, sum;
for (int i = len1 - 1, j = len2 - 1; i >= 0 || j >= 0; i--, j--) {
if (i < 0)
sum = s2[j] - '0';
else if (j < 0)
sum = s1[i] - '0';
else
sum = s1[i] - '0' + s2[i] - '0';
sum += carry;
result.insert(result.begin(), (sum % 10 + '0'));
carry = sum / 10;
}
if (carry) {
result.insert(result.begin(), carry + '0');
}
return result;
}

int main() {
string s;
int n, count = 0;
cin >> s;
cin >> n;
while (n--) {
string sx = s;
reverse(s.begin(), s.end());
if (s == sx) break;
else {
s = add(sx, s);
count+
99c7
+;
}
}
cout << s << endl << count << endl;
return 0;
}
C++ string assign()赋值常用方法
C++中string类下的begin,end,rbegin,rend的用法
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: