您的位置:首页 > 其它

HDU-1075 What Are You Talking About(map)

2018-03-04 14:01 351 查看
HDU-1075 What Are You Talking About(map)

[align=left]Problem Description[/align] Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 
[align=left]Input[/align] The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 
[align=left]Output[/align] In this problem, you have to output the translation of the history book.
 
[align=left]Sample Input[/align]
START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END 
[align=left]Sample Output[/align]
hello, i'm from mars.
i like earth!

Hint
Huge input, scanf is recommended.
#include<iostream>
#include<map>
#include<cstdio>
#include<cstring>
using namespace std;
map<string,string> si;
int main()
{   
    int len;
    char ccc[3100];//一行3000个单词,所有符号都算一个,开3000数组的意思
    string s1,s2;
    cin>>s1;   //这样很好地处理了被忽略的START
    while(cin>>s1,s1!="END")
    {
        cin>>s2;
        si[s2]=s1;
    }
    cin>>s1;
    getchar(); // gets看下面一行为空,就以为为空,但实际不是这样。所以要用一个getchar吸收回车
    int i;
    while(!0)
    {
        gets(ccc);
        if(strcmp(ccc,"END")==0)
        break;
        else
        {   
         
4000
   len=strlen(ccc);
             s2="";
            for(i=0;i<len;i++)
            {
            
                   if(ccc[i]<'a'||ccc[i]>'z') //判断什么时候输出字符串
                  {      
                         if(s2=="")
                         cout<<ccc[i];
                         else
                          {
                            if(si[s2]=="")
                            {
                             cout<<s2;
                             cout<<ccc[i];
                            }
                            else
                            {
                            cout<<si[s2];
                            cout<<ccc[i];
                            }
                             s2="";
                          }
                  }
                   else
                   s2+=ccc[i];
            }
        }
        printf("\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: