您的位置:首页 > 其它

POJ-3273 Monthly Expense(二分)

2018-03-03 20:10 417 查看
POJ-3273 Monthly Expense(二分)

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.
FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.
FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.
Input Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day Output Line 1: The smallest possible monthly limit Farmer John can afford to live with. Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
#define MAX 100010
int a[MAX];
int main()
{
    int n,m;
    int left=-100,right=0,mid,sum,cnt;
    scanf("%d%d",&n,&m);
    int i;
    for(i=0;i<n;i++)
    {
      scanf("%d",&a[i]);
      left=max(left,a[i]);
      right+=a[i];
    }
    if(m==1)
    printf("%d\n",right);
    else
    {  
       while(left<right)
       {  
          cnt=0;
          sum=0;
          mid=(right-left)/2+left;
          for(i=0;i<n;i++)
          {
             if(sum+a[i]>mid)
             {
                 cnt++;
                 sum=a[i];
             }
             else
             sum+=a[i];
          }
           cnt++;
           if(cnt>m)
           left=mid+1;
           else
           right=mid;
       }
       printf("%d\n",left);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: