您的位置:首页 > 其它

POJ - 3177 Redundant Paths (双连通分量+缩点)

2018-03-03 14:25 295 查看
Redundant Paths
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17110 Accepted: 7117
DescriptionIn order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only travel on Official Paths when they move from one field to another.

Given a description of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way.

There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.InputLine 1: Two space-separated integers: F and R

Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.OutputLine 1: A single integer that is the number of new paths that must be built.Sample Input7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7Sample Output2HintExplanation of the sample:

One visualization of the paths is:
1   2   3
+---+---+
|   |
|   |
6 +---+---+ 4
/ 5
/
/
7 +
Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions.
1   2   3
+---+---+
:   |   |
:   |   |
6 +---+---+ 4
/ 5  :
/     :
/      :
7 + - - - -
Check some of the routes:
1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2
1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4
3 – 7: 3 –> 4 –> 7 and 3 –> 2 –> 5 –> 7
Every pair of fields is, in fact, connected by two routes.

It's possible that adding some other path will also solve the problem (like one from 6 to 7). Adding two paths, however, is the minimum.SourceUSACO 2006 January Gold

题意:最少要加多少条边,才能使得整个图双联通。

解题思路:tarjan算法求双连通分量(其实跟强连通分量是一样的)。然后缩点形成一棵树,求这颗树有多少个叶子节点即可。答案就是(叶子节点+1)/2.注意有重边。

#include <iostream>
#include <algorithm>
#include <string.h>
#include <vector>
#include <memory.h>
#include <bitset>
#include <map>
#include <deque>
#include <math.h>
#include <stdio.h>
using namespace std;
using namespace std;

typedef long long int ll;

const int MAXN = 10005;

vector<int> G[MAXN];
int N, M;
int color[MAXN];
int dfn[MAXN];
int low[MAXN];
int vis[MAXN];
int instack[MAXN];
int sta[MAXN];
int cnt = 0;
int vistime = 1;
int col = 1;

int indegree[MAXN];
int outdegree[MAXN];

void init()
{

for (int i = 0; i < MAXN; i++)
G[i].clear();
memset(color, 0, sizeof(color));
memset(dfn, 0, sizeof(dfn));
memset(low, 0, sizeof(low));
memset(vis, 0, sizeof(vis));
memset(instack, 0, sizeof(instack));
memset(sta, 0, sizeof(sta));
memset(indegree, 0, sizeof(indegree));
memset(outdegree, 0, sizeof(outdegree));
cnt = 0;
vistime = 1;
col = 1;
}

void tarjan(int v1, int fa)
{
dfn[v1] = low[v1] = vistime;
vistime++;

vis[v1] = 1;

sta[cnt++] = v1;
instack[v1] = 1;

int flag = 0; //因为有重边,所以要记录往回走了多少次。
for (int i = 0; i < G[v1].size(); i++)
{
if (G[v1][i] == fa && !flag)
{
flag = 1;
continue;
}

if (!vis[G[v1][i]])
{
tarjan(G[v1][i], v1);
low[v1] = min(low[v1], low[G[v1][i]]);
}
else if (instack[G[v1][i]])
low[v1] = min(low[v1], dfn[G[v1][i]]);
}
if (dfn[v1] == low[v1])
{
int temp;
do
{
temp = sta[--cnt];
color[temp] = col; //缩点
instack[temp] = 0;

} while (temp != v1);
col++;
}
}

void SD()
{
for (int i = 1; i <= N; i++)
{
for (int j = 0; j < G[i].size(); j++)
{
if (color[i] != color[G[i][j]])
{
outdegree[color[i]]++;
}
}
}
}

int main()
{

scanf("%d%d", &N, &M);
init();
int temp;
for (int i = 1; i <= M; i++)
{
int a, b;
scanf("%d%d", &a, &b);
G[a].push_back(b);
G[b].push_back(a);
}

for (int i = 1; i <= N; i++)
if (!vis[i])
tarjan(i, -1);

SD();

int ans = 0;
for (int i = 1; i < col; i++)
{
if (outdegree[i] == 1)
ans++;
}
printf("%d\n", (ans + 1) / 2);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: