您的位置:首页 > 产品设计 > UI/UE

Integer Inquiry

2018-03-03 10:28 225 查看
One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of
powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
“This supercomputer is great,” remarked Chip. “I only wish Timothy were here to see these results.”
(Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky
apartments on Third Street.)
Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger.
Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no
VeryLongInteger will be negative).
The final input line will contain a single zero on a line by itself.

Output
Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output
370370367037037036703703703670
PS:题就是说让你加n个大数,直到输入0为止。主要运用高精度加法。
AC代码:
#include<iostream>
#include<cstring>
using namespace std;
char str[100][1000000];
int a[100][1000000],b[1000000],n=0;
int main()
{
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
for(int i=0;;i++)
{
n++;
scanf("%s",str[i]);
if(str[i][0]=='0')
break;

}
int len,max=0;
for(int i=0;i<n;i++)
{
len=strlen(str[i]);
for(int j=0;j<len;j++)
a[i][len-j]=str[i][j]-'0';
if(len>max)
max=len;
}
int l=1;
while(l<=max)
{
for(int i=0;i<n;i++)
b[l]+=a[i][l];
b
4000
[l+1]+=b[l]/10;
b[l]%=10;
l++;
}
while(b[l]==0&&l>0)
l--;
if(l==0)
printf("0");
else
{
for(;l>0;l--)
printf("%d",b[l]);
}
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: