您的位置:首页 > 其它

HDU 1241 Oil Deposits

2018-03-02 10:58 393 查看
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output
are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2
题意:给你一片地,要找出里面有多少油田,油田表示为@  要求是只要一个@的八面有@  这就算一个油田。
解析:可通过广搜,然后将连接的油田全部转化成地,看能分别转化几次,就有几块油田。不懂
4000
可以看看下面代码。

代码:
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
char str[101][101];
int fx[8][2]={0,1,0,-1,1,0,-1,0,1,-1,1,1,-1,-1,-1,1};
int n,m;
int check(int x,int y)
{
    if(x>=0&&x<m&&y>=0&&y<n&&str[x][y]=='@')
        return 1;
    return 0;
}
void dfs(int x,int y)
{
    int x1,y1;
    for(int i=0;i<8;i++)
    {
        x1=x+fx[i][0];
        y1=y+fx[i][1];
        if(check(x1,y1))
        {
            str[x1][y1]='*';
            dfs(x1,y1);
        }
    }
}
int main()
{

    while(scanf("%d%d",&m,&n)!=EOF)
    {
        if(m==0)
            break;
        int sum=0;
        for(int i=0;i<m;i++)
            scanf("%s",str[i]);
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
                if(str[i][j]=='@')
                {
                     dfs(i,j);
                        sum++;
                }

        printf("%d\n",sum);
    }
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: