您的位置:首页 > 产品设计 > UI/UE

poj 3061 Subsequence

2018-03-01 22:17 337 查看
原题:

Subsequence

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 18219 Accepted: 7791

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2

10 15

5 1 3 5 10 7 4 9 2 8

5 11

1 2 3 4 5

Sample Output

2

3

Source

Southeastern Europe 2006

中文:

给你一个长度为n序列,然后给你一个数s。

现在让你找到一个最短的连续子段和,使得这个和大于或等于s。

//#include<bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<limits.h>
using namespace std;

int t, n, s;
int a[100001];
int main()
{
ios::sync_with_stdio(false);
cin >> t;
while (t--)
{
cin >> n >> s;
for (int i = 1; i <= n; i++)
{
cin >> a[i];
}
int ans = INT_MAX, tmp = 0, pre = 1;
int i=1;
while(true)
{
while(tmp<s&&i<=n)
{
tmp+=a[i];
i++;
}
if(tmp<s)
break;

ans=min(ans,i-pre);
tmp-=a[pre];
pre++;
}
if(ans>n)
ans=0;
cout << ans << endl;
}
return 0;
}


解答:

挑战程序设计竞赛上面的例题,在这本书里叫做尺取法。实际上就是滑动窗口,设置两个下标i,j,下标i往前走,并累加和,直到满足总和大于s时,下标j向前走,总和减去a[j],记录滑动窗口大小即可。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: