您的位置:首页 > 其它

POJ 3169 Layout (差分约束系统)

2018-03-01 22:04 393 查看
任重而道远
题目大意:
大概题意:有N个点,其中有ml个限制条件:点a,点b,的最长距离为d,有md个限制条件,点a,点b,的最短距离为d;点按序号顺序排,求第一个点到最后一个点的最长距离。Description
Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.InputLine 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.OutputLine 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.Sample Input4 2 1
1 3 10
2 4 20
2 3 3Sample Output27HintExplanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

AC代码:#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>

using namespace std;

const int N=1010;
const int M=201000;
const int INF=100000000;
struct edge {
int tov, val, nxt;
}e[M];
int head
, dis
, cnt
, len, n, ml, md, num;
bool vis
;

void add_edge ( int u, int v, int val ) {
num++;
e[num].tov = v;
e[num].val = val;
e[num].nxt = head[u];
head[u] = num;
}

int spfa () {
queue<int> q;
int front = 1;
q.push (front);
vis[front] = true;
cnt[front] = 1;
dis[front] = 0;
while (!q.empty ()) {
int cur = q.front ();
q.pop ();
vis[cur] = false;
for (int i = head[cur]; i; i = e[i].nxt) {
int id = e[i].tov;
if (dis[id] > dis[cur] + e[i].val) {
dis[id] = dis[cur] + e[i].val;
if (!vis[id]) {
if (++cnt[id] > n)
return -1;
q.push (id);
vis[id] = true;
}
}
}
}
if (dis
== INF)
return -2;
return dis
;
}

void init () {
num = 0;
memset (head, 0, sizeof (head));
memset (cnt, 0, sizeof (cnt));
memset (dis, INF, sizeof (dis));
memset (vis, false, sizeof (vis));
}

int main (){
scanf("%d%d%d",&n,&ml,&md);
init ();
for ( int i = 1; i <=n; i ++) {
dis[i] = INF;
add_edge (i, i - 1, 0);
}
for (int i = 0; i < ml; i ++) {
int u, v, val;
scanf ("%d%d%d",&u, &v, &val);
add_edge (u, v, val);
}
for (int i = 0; i < md; i ++) {
int u, v, val;
scanf ("%d%d%d",&u, &v, &val);
add_edge (v, u, -val);
}
printf ("%d",spfa ());
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: