您的位置:首页 > 其它

HDU 1016 Prime Ring Problem DFS(总结了一下模板)

2018-02-28 21:38 816 查看
本题链接:HDU1016
自我总结模板:
   /* DFS 的模板题
可以使用模板
if()
....
else
{
for(...)
if()//满足条件 继续往下搜
dfs(m+1);
vis[]=1//不满足的话回溯 注 这个vis 不具有代表性
}
*/

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 59064    Accepted Submission(s): 25626


[align=left]Problem Description[/align]A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



 
[align=left]Input[/align]n (0 < n < 20).
 
[align=left]Output[/align]The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 
[align=left]Sample Input[/align]
6

[align=left]Sample Output[/align]
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2题目大意:给你一个n(n<20) 从1-n 中找出6个数,使得,每相邻的两个数都得是素数,提示:第一个数一定是 1;
题目思路:这种填数的,一般会用DFS,减少枚举的数目
小技巧:1 由于所求数据在20以内,相加之后不会超过40,所有可以提前预处理一下做个40以内的素数判断数组,以节约用时。
                2 可以使用一般的素数判断方法,也可以使用线性筛
#include<iostream>
#include<cstring>
using namespace std;
int a[41]={1};// n<20 所以只需要把 40以内的素数打表就可以了
int b[6];// 素数环的六个数
int vis[20];//标记数组
int n;
void prime()//找到40 以内所有的素数 如果i 为素数 a[i]=1 否则 a[i]=0;
{
memset(a,1,sizeof(a));
a[1]=0;
for(int i=2;i<=40;i++)
{
for(int j=2;j*j<=i;j++)
if(i%j==0)
{
a[i]=0;
break;
}
}
}
void dfs(int m)
{
if(m==n&&a[b[n-1]+b[0]])//已经判断了n个数,再判断一下 b[n-1]+b[0] 也是素数
{
for(int i=0;i<n-1;i++)//输出
cout<<b[i]<<" ";
cout<<b[n-1]<<endl;
}
else
{
for(int i=2;i<=n;i++)
if(vis[i]&&a[b[m-1]+i])
{
vis[i]=0;//符合条件时,标记为0,表示该数已经使用,不能再用了
b[m]=i;
dfs(m+1);
vis[i]=1;//回溯
}
}
}
int main()
{
int t=1;
prime();

while(cin>>n)
{
memset(vis,1,sizeof(vis));
cout<<"Case "<<t++<<":"<<endl;
vis[1]=0;
b[0]=1;
dfs(1);//因为 第一个数已经默认为 1了,所以不需要从第0层开始从 第 1层开始
cout<<endl;
}

return 0;
}
         
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  DFS