您的位置:首页 > Web前端

POJ 1274 The Perfect Stall(最大匹配)

2018-02-28 13:00 337 查看

                                    The Perfect Stall 

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 
InputThe input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.OutputFor each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.Sample Input
5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2
Sample Output
4
题意大概:每头牛都有自己喜欢待的牛栏,然后我们来匹配,看最多能匹配多少对牛住进自己喜欢的的牛栏。二分图基础概念:



思路:二分图 ,牛和牛栏看成两个集合。

二分图最大匹配模板题代码如下:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
using namespace std;
const int maxn = 200+5;
int Next[maxn*200],Lext[maxn],To[maxn*200],vis[maxn],dis[maxn];
int cnt;
void init()
{
memset(Lext,-1,sizeof(Lext));
memset(vis,0,sizeof(vis));
memset(dis,-1,sizeof(dis));
}
void add(int u,int v)
{
Next[++cnt]=Lext[u];
Lext[u]=cnt;
To[cnt]=v;
}
bool dfs(int x)
{
for(int i=Lext[x]; i!=-1; i=Next[i])
{
int y=To[i];
if(!vis[y])
{
vis[y]=1;
if(dis[y]==-1||dfs(dis[y]))
{
dis[y]=x;
return true;
}
}
}
return false;
}
int main()
{
int n,m,v;
while(~scanf("%d %d",&n,&m))
{
init();
for(int u=1; u<=n; u++)
{
scanf("%d",&m);
for(int j=0; j<m; j++)
{
scanf("%d",&v);

9047
add(u,v);
}

}
int ans=0;
for(int i=1; i<=n; i++)
{
memset(vis,0,sizeof(vis));
if(dfs(i)) ans++;
}
cout<<ans<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: