您的位置:首页 > 其它

poj 3461 (kmp)

2018-02-24 23:15 204 查看
Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 45343 Accepted: 18135
DescriptionThe French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
InputThe first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
OutputFor every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIANSample Output1
3
0SourceBAPC 2006 Qualification
[Submit]   [Go Back]   [Status]   [Discuss]#include <iostream>
#include <cstring>
#define Max(a,b) a>b?a:b
#define LL long long
#define maxn 100000
using namespace std;
int Nt[1000010];
void getnext(char *p)
{
int j=0;
int k=-1;
Nt[0]=-1;
int len=strlen(p);
while(j<len-1)
{
if(k==-1||p[k]==p[j])
{
Nt[++j]=++k;
}else k=Nt[k];
}
}
int kmp(char *p,char *s)
{
int pl=strlen(p);
int sl=strlen(s);
int i=0,k=0;
int ans=0;
while(k<sl)
{
if(i==-1||p[i]==s[k])
{
i++;k++;
}else i=Nt[i];
if(i==pl){ans++;i=Nt[i];}//this is the key
}
return ans;
}
int main()
{
ios::sync_with_stdio(0);
char ptr[100010];//字符数组要开稍大一点不然会wa。
char str[1000010];
int n;cin>>n;
while(n--)
{
memset(Nt,0,sizeof(Nt));
cin>>ptr>>str;
getnext(str);
cout<<kmp(ptr,str)<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: