您的位置:首页 > 其它

HDU-1213 How Many Tables(并查集)

2018-02-24 13:53 351 查看
HDU-1213 How Many Tables

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int sum;
int fa[1200];
int find(int x)
{
    if(x!=fa[x])
    fa[x]=find(fa[x]);
    return fa[x];
}
void unionxx(int x,int y)
{
    int xn=find(x);
    int yn=find(y);
    if(xn==yn)
    return;
    sum--;  
    fa[yn]=xn;    
}
int main()
{
    int t,n,m,i;
    int a,b;
    scanf("%d",&t);
    while(t--)
{
      scanf("%d%d",&n,&m);
      sum=n;
      for(i=1;i<=n;i++)
      fa[i]=i;
      for(i=1;i<=m;i++)
    {
          scanf("%d%d",&a,&b);
          unionxx(a,b);
    }
    printf("%d\n",sum);
    getchar();//用来接收一个换行
}
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: