您的位置:首页 > 其它

HDU2055 An easy problem【水题】

2018-02-24 08:38 344 查看

An easy problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28633    Accepted Submission(s): 18657


[align=left]Problem Description[/align]we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x). 
[align=left]Input[/align]On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number. 
[align=left]Output[/align]for each case, you should the result of y+f(x) on a line. 
[align=left]Sample Input[/align]
6R 1P 2G 3r 1p 2g 3 
[align=left]Sample Output[/align]
191810-17-14-4

问题链接HDU2055 An easy problem

问题简述:(略)

问题分析:(略)

程序说明:输入格式有点特殊。使用条件表达式会是的程序代码变得比较简洁。
题记:(略)

参考链接:(略)

AC的C++语言程序如下:/* HDU2055 An easy problem */

#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
int n, a;
char c;

scanf("%d%*c", &n);
while (n--) {
scanf("%c%d%*c", &c, &a);

printf("%d\n", a + (c < 'a' ? c - 'A' + 1 : 'a' - c - 1));
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: