您的位置:首页 > 其它

1091. Acute Stroke (30)

2018-02-23 14:45 246 查看
1091. Acute Stroke (30)

时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B

判题程序 Standard 作者 CHEN, Yue

One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M by N matrix, and the maximum resolution is 1286 by 128); L (<=60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M by N matrix of 0’s and 1’s, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1’s to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are “connected” and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.



Figure 1

Output Specification:

For each case, output in a line the total volume of the stroke core.

Sample Input:

3 4 5 2

1 1 1 1

1 1 1 1

1 1 1 1

0 0 1 1

0 0 1 1

0 0 1 1

1 0 1 1

0 1 0 0

0 0 0 0

1 0 1 1

0 0 0 0

0 0 0 0

0 0 0 1

0 0 0 1

1 0 0 0

Sample Output:

26

这里的三维用的是z x y,而不是 x,y,z ,是为了方便调试


#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <queue>

using namespace std;
const int MaxN = 410;

int pixel[66][1290][136] = { false };
int isInq[66][1290][136] = { false };

int dx[6] = { 0, 0 ,-1, 1, 0, 0 };
int dy[6] = { 0, 0 , 0, 0,-1, 1 };
int dz[6] = { 1, -1, 0, 0, 0, 0 };

typedef struct coordinate
{
int x;
int y;
int z;
}COORD;

bool Juede(int x, int y, int z)
{
if (!pixel[z][x][y] || isInq[z][x][y]) return false;
return true;
}

int BFS(int x, int y, int z)
{
int n = 0;

if (Juede(x, y, z))
{
queue<COORD> que;
COORD front,tmp;
front.x = x, front.y = y, front.z = z;
que.push(front); isInq[z][x][y] = true;

while (que.size())
{
front = que.front(); que.pop();
++n;

for (int i = 0; i < 6; ++i)
{
tmp.x = front.x + dx[i];
tmp.y = front.y + dy[i];
tmp.z = front.z + dz[i];
if (Juede(tmp.x, tmp.y, tmp.z))
{
que.push(tmp);
isInq[tmp.z][tmp.x][tmp.y] = true;
}
}
}
}

return n;
}

int main()
{
#ifdef _DEBUG
freopen("data.txt", "r+", stdin);
#endif

std::ios::sync_with_stdio(false);

int M, N, L, T ,ans = 0;
cin >> M >> N >> L >> T;

for (int z = 1; z <= L; ++z)
{
for (int x = 1; x <= M; ++x)
{
for (int y = 1; y <= N; ++y)
{
cin >> pixel[z][x][y];
}
}
}

for (int z = 1; z <= L; ++z)
{
for (int x = 1; x <= M; ++x)
{
for (int y = 1; y <= N; ++y)
{
int v = BFS(x, y, z);
if (v >= T)
ans += v;
}
}
}

cout << ans;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat甲级 1091