您的位置:首页 > 其它

1036. Boys vs Girls (25)

2018-02-21 22:18 288 查看
This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.
Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:
For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.
Sample Input 1:3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1:
Mary EE990830
Joe Math990112
6
Sample Input 2:
1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA
题目大意:
这次要求你区分所有男生中的最低分和所有女生中的最高分。
输入规格:
每个输入文件包含一个测试用例。每个测试用例包含一个正整数N,接下来是N行学生信息。每行包含一个学生的姓名、性别、ID和年级,由空格隔开,ID和姓名是不带空格的不超过10个字符的字符串,性别是F和M,成绩是一个在1到100之间的整数。保证所有的成绩都是不同的。
输出规范:
对于每个测试用例,输出3行。第一行是成绩最高的女生的名字和ID,第二行是成绩最低的男生的姓名和ID。第三行给出女生和男生成绩之差。如果一个这样的学生缺席了,对应行输出“缺席”,在第三行输出“NA”。

代码:#include<stdio.h>
#include<string.h>
int main()
{
int i,j,n,m=0,f=0,k,t,grade,mgrade=200,fgrade=-1;
char name[20],sex[5],ID[20],mname[20],mID[20],fname[20],fID[20];
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%s %s %s %d",name,sex,ID,&grade);
if(sex[0]=='M')
{
m++;
if(mgrade>grade)
{
mgrade=grade;
strcpy(mname,name);
strcpy(mID,ID);
}
}
else
{
f++;
if(fgrade<grade)
{
fgrade=grade;
strcpy(fname,name);
strcpy(fID,ID);
}
}
}
if(m==0)
{
printf("%s %s\n",fname,fID);
printf("Absent\n");
printf("NA");
}
else if(f==0)
{
printf("Absent\n");
printf("%s %s\n",mname,mID);
printf("NA");
}
else
{
printf("%s %s\n",fname,fID);
printf("%s %s\n",mname,mID);
printf("%d",fgrade-mgrade);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: