您的位置:首页 > 其它

pat 判断给定插入序列是否为BST的先序遍历序列

2018-02-21 18:24 351 查看
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:The left subtree of a node contains only nodes with keys less than the node's key.
The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.Input Specification:Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.Output Specification:For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8#include<stdio.h>
#include<queue>
#include<vector>
#include<algorithm>
//BST Binary Search Tree
//若修改值则*root指向的data可修改
//要修改树形状
//判断给定插入顺序能够构成BST,方法:对构造生成的树进行先序遍历及镜像先序遍历
using namespace std;
struct Node{
int data;
Node *lchild;
Node *rchild;
};
int num;//最后少输出空格
//镜像和非镜像的区别是左右子树的遍历顺序相反,遍历结果录入vector进行比较即可
void pre(Node *root,vector<int> &v){
if(root==NULL) return;
v.push_back(root->data);
if(root->lchild) pre(root->lchild,v);
if(root->rchild) pre(root->rchild,v);
}

void preM(Node *root,vector<int> &v){
if(root==NULL) return;
v.push_back(root->data);
if(root->rchild) preM(root->rchild,v);
if(root->lchild) preM(root->lchild,v);
}

void post(Node *root,vector<int> &v){
if(root==NULL) return;
if(root->lchild) post(root->lchild,v);
if(root->rchild) post(root->rchild,v);
v.push_back(root->data);
}

void postM(Node *root,vector<int> &v){
if(root==NULL) return;
if(root->rchild) postM(root->rchild,v);
if(root->lchild) postM(root->lchild,v);
v.push_back(root->data);
}

void insert(Node *&root,int x){//插入到一个不存在的地方
if(root==NULL){
root=new Node;
root->data=x;
root->lchild=root->rchild=NULL;
}
else if(x<root->data){
insert(root->lchild,x);
}
else
insert(root->rchild,x);
}

int main(){
vector<int> origin,pres,preMs,posts,postMs;
int n,temp;
scanf("%d",&n);
Node *root=NULL;
for(int i=0;i<n;i++){
scanf("%d",&temp);
origin.push_back(temp);
insert(root,temp);
}
pre(root,pres);
preM(root,preMs);
if(pres==origin){
printf("YES\n");
post(root,posts);
int len=posts.size();
for(int i=0;i<len;i++)
if(i!=len-1) printf("%d ",posts[i]);
else printf("%d\n",posts[i]);
}
else if(preMs==origin){
printf("YES\n");
postM(root,postMs);
int len=postMs.size();
for(int i=0;i<len;i++)
if(i!=len-1) printf("%d ",postMs[i]);
else printf("%d\n",postMs[i]);
}
else printf("NO\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐