您的位置:首页 > 其它

Maximum Product UVA - 11059

2018-02-21 16:57 441 查看
Given a sequence of integers S = {S1,S2,...,Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.
Input Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).
Output
For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.
Sample Input
3 2 4 -3
5 2 5 -1 2 -1
Sample Output
Case #1: The maximum product is 8.
Case #2: The maximum product is 20.题目大意:输入n个元素组成的序列S,找出一个乘积最大的连续子序列。如果这个最大的乘积不是正数,应输出0。1<=n<=18,-10<=Si<=10。解析:枚举起点和终点,求最大乘积。
#include <cstdio>
#include <algorithm>
#include <bits/stdc++.h>
using namespace std;

int main()
{
int n;
int i,j,k,ct=0,a[20];
long long int sum,_max;
while(cin>>n)
{
ct++;_max=0;
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
for(i=0;i<n;i++)
{
for(j=i;j<n;j++)
{
sum=1;
for( k=i;k<=j;k++)
{
sum*=a[k];
}
if(sum>_max)
_max=sum;
}
}
cout<<"Case #"<<ct<<": The maximum product is "<<_max<<'.'<<endl<<endl;

}
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  UVA oj