您的位置:首页 > 其它

HDU 1394 Minimum Inversion Number

2018-02-20 16:21 495 查看

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22542    Accepted Submission(s): 13419


[align=left]Problem Description[/align]The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 
[align=left]Input[/align]The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 
[align=left]Output[/align]For each case, output the minimum inversion number on a single line.
 
[align=left]Sample Input[/align]
10
1 3 6 9 0 8 5 7 4 2 
[align=left]Sample Output[/align]
16 开始满足条件的若有sum个,则把t从第一个移到最后一个后,逆序数
减少了t个,增加了n-t-1个,因此,此时的sum=sum-t+n-t-1;
因为n在5000以内,因此可以O(n*n)求解。
如果数据在扩大,则可以线段树求解。

暴力求解:

#include<bits/stdc++.h>
using namespace std;
const int maxn=5009;
int a[maxn];
int main()
{
int n,m,i,j;
while(~scanf("%d",&n))
{
int sum=0,ans;
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
for(j=1;j<i;j++)
if(a[j]>a[i])sum++;
}
ans=sum;
for(i=1;i<=n;i++)
{
sum=sum-a[i]+(n-a[i]-1);
ans=min(ans,sum);
}
printf("%d\n",ans);
}
return 0;
}

线段树求解:

#include<bits/stdc++.h>
using namespace std;
const int maxn=5009;
int a[maxn],s[maxn<<2];
int query(int L,int R,int l,int r,int rt)
{
if(L<=l&&R>=r)return s[rt];
int m=(l+r)>>1;
int ans=0;
if(L<=m) ans+=query(L,R,l,m,rt<<1);
if(R>m)ans+=query(L,R,m+1,r,rt<<1|1);
return ans;
}
void update(int L,int l,int r,int rt)
{
if(l==r)
{
s[rt]++;
return;
}
int m=(l+r)>>1;
if(L<=m) update(L,l,m,rt<<1);
else update(L,m+1,r,rt<<1|1);
s[rt]=s[rt<<1]+s[rt<<1|1];
}
int main()
{
int n,m,i,j;
while(~scanf("%d",&n))
{
memset(s,0,sizeof(s));
int sum=0,ans;
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
sum+=query(a[i]+1,n,1,n,1);
//查询a[i]+1~n中已存在的个数。
update(a[i],1,n,1);//更新个数。
}
ans=sum;
for(i=1;i<=n;i++)
{
sum=sum-a[i]+(n-a[i]-1);
ans=min(ans,sum);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: