您的位置:首页 > 其它

POJ 3352 Road Construction(双连通分量Tarjan算法)

2018-02-18 22:12 453 查看
本题考察的无向图的边双连通分量

Road Construction(POJ 3352

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 12831 Accepted: 6489

Description

It’s almost summer time, and that means that it’s almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input

Sample Input 1

10 12

1 2

1 3

1 4

2 5

2 6

5 6

3 7

3 8

7 8

4 9

4 10

9 10

Sample Input 2

3 3

1 2

2 3

1 3

Sample Output

Output for Sample Input 1

2

Output for Sample Input 2

0

附上AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <stack>
#include <cstring>
using namespace std;
int n,m;
const
b61d
int MAXN = 1004;
struct Edge{
int next,to;
} edge[MAXN*5];
int head[MAXN];
int DFN[MAXN],low[MAXN],belong[MAXN],du[MAXN];

int ecnt = 1,ji,ans,cntt;//cntt表示边双连通分量的个数
stack<int>s;
void add(int u,int v){
edge[ecnt].to = v;
edge[ecnt].next = head[u];
head[u] = ecnt++;
}
void tarjan(int x,int fa){
low[x] = DFN[x] = ++ji;
s.push(x);
for(int i = head[x]; i; i = edge[i].next){
int to = edge[i].to;
if(to != fa){
if(DFN[to] == -1){
tarjan(to,x);
low[x] = min(low[to],low[x]);
}else{
low[x] = min(low[x],DFN[to]);
}
}
}
if(low[x] > DFN[fa]){
cntt++;
while(1){
int temp = s.top();
s.pop();
belong[temp] = cntt;
if(temp == x)break;
}
}
}
int main(){
scanf("%d %d",&n,&m);
for(int i = 1; i <= n; i++){
DFN[i] = -1;
}
for(int i = 1; i <= m; i++){
int u,v;
scanf("%d %d",&u,&v);
add(u,v);
add(v,u);
}
tarjan(1,0);
for(int i = 1; i <= n; i++){
for(int j = head[i]; j; j = edge[j].next){
int to = edge[j].to;
if(belong[to] != belong[i]){
du[belong[to]]++;
du[belong[i]]++;
}
}
}
for(int i = 1; i <= n; i++){
du[i] /=2;
}
for(int i = 1; i <= n; i++){
if(du[i] == 1){
ans++;
}
}
ans = (ans+1)/2;
cout<<ans<<endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: