您的位置:首页 > 其它

HDU 1233 还是畅通工程 并查集 (单向点连通)

2018-02-18 11:37 302 查看
Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最小的公路总长度。
 

Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
 

Sample Output
3
5
题意:给出n*(n-1)/2条路,用最小的费用去构造可以实现任意2条路都畅通的路
思路:贪心 按照费用从小到大排序路再利用并查集思路#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <cmath>
using namespace std;
typedef long long ll;
const int N = 1005;
struct node
{
int l;
int r;
int c;
}a[10005];
int parent
;
bool cmp(node x,node y)
{
return x.c<y.c;
}
int root(int x)
{
return parent[x] == x ? x: parent[x]=root(parent[x]);
}
int main()
{
int n;
while(scanf("%d",&n)==1&&n!=0)
{
int sum=0;
for(int i=0;i<=n;i++)
parent[i]=i;
int len=n*(n-1)/2;
for(int i=0;i<len;i++)
scanf("%d%d%d",&a[i].l,&a[i].r,&a[i].c);
sort(a,a+len,cmp);
for(int i=0;i<len;i++)
{
int fx=root(a[i].l);
int fy=root(a[i].r);
if(fx!=fy) //二者没有联通
{
sum+=a[i].c;
parent[fy]=fx;
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: