您的位置:首页 > 其它

Trees Made to Order_catalan数_2018_2_17

2018-02-17 17:14 375 查看
Trees Made to Order
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7474 Accepted: 4264
DescriptionWe can number binary trees using the following scheme:
The empty tree is numbered 0.
The single-node tree is numbered 1.
All binary trees having m nodes have numbers less than all those having m+1 nodes.
Any binary tree having m nodes with left and right subtrees L and R is numbered n such that all trees having m nodes numbered > n have either Left subtrees numbered higher than L, or A left subtree = L and a right subtree numbered higher than R.

The first 10 binary trees and tree number 20 in this sequence are shown below:



Your job for this problem is to output a binary tree when given its order number.
InputInput consists of multiple problem instances. Each instance consists of a single integer n, where 1 <= n <= 500,000,000. A value of n = 0 terminates input. (Note that this means you will never have to output the empty tree.)OutputFor each problem instance, you should output one line containing the tree corresponding to the order number for that instance. To print out the tree, use the following scheme:

A tree with no children should be output as X.
A tree with left and right subtrees L and R should be output as (L')X(R'), where L' and R' are the representations of L and R.
If L is empty, just output X(R').
If R is empty, just output (L')X.
Sample Input1
20
31117532
0Sample OutputX
((X)X(X))X
(X(X(((X(X))X(X))X(X))))X(((X((X)X((X)X)))X)X)SourceEast Central North America 2001#include<iostream>
#include<cstdio>
using namespace std;

const int N=20;
int cal
={1,1},sum
={0,1};

int count(int &n){
int t=1;
while(n>cal[t]){
n-=cal[t];
t++;
}
return t;
}

void print(int all,int m){
int r=all-1;
int l=0;
while(m>cal[r]*cal[l]){
m-=cal[r]*cal[l];
--r;
++l;
}
int k;
if(l>0){
putchar('(');
k=m/cal[r];
if(m%cal[r]!=0)k++;
print(l,k);
putchar(')');
}
putchar('X');
if(r>0){
putchar('(');
k=(m-1)%cal[r]+1;
print(r,k);
putchar(')');
}
}

int main(){
for(int i=2;i<19;i++){
for(int j=0;j<i;j++)
cal[i]+=cal[j]*cal[i-1-j];
sum[i]=cal[i]+sum[i-1];
}
int n;
while(scanf("%d",&n),n){
int nodenumber=count(n);
print(nodenumber,n);puts("");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: