您的位置:首页 > 其它

Prime Ring Problem

2018-02-16 14:00 183 查看
Prime Ring Problem

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6

8

Sample Output

Case 1:

1 4 3 2 5 6

1 6 5 2 3 4

Case 2:

1 2 3 8 5 6 7 4

1 2 5 8 3 4 7 6

1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int n,ans[25],vis[25];

int prime(int x)  //判断是否为素数
{
for(int i=2;i*i<=x;i++)
if(x%i==0)
return 0;
return 1;
}

void dfs(int t)
{
if(t==n && prime(ans
+1))
{
for(int i=1;i<n;i++)
printf("%d ",ans[i]);
printf("%d\n",ans
);
return ;
}
for(int i=2;i<=n;i++)
{
if(!vis[i] && prime(ans[t]+i))
{
ans[t+1]=i;
vis[i]=1;
dfs(t+1);
vis[i]=0;
}
}
}

int main()
{
int k=1;
while(scanf("%d",&n)!=EOF)
{
memset(vis,0,sizeof(vis));
printf("Case %d:\n",k++);
if(n%2==1 && n!=1)  //若n为奇数(且不为1),则一定不满足条件(环内一定有两个奇数相邻)
{
printf("\n");
continue;
}
ans[1]=vis[1]=1;
dfs(1);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: