您的位置:首页 > 其它

*寒假水48—— The sum problem

2018-02-14 23:47 337 查看
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.InputInput contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0. 
OutputFor each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case. 
Sample Input
20 10
50 30
0 0
Sample Output
[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]

#include<iostream>
#include<cmath>

using namespace std;

int main()
{
long long m,n;
int i,j,chen;
while(cin>>m>>n&&(m||n)){
for(i=sqrt(n*2.0);i>=1;--i){
chen=n-(i*i+i)/2;    //这儿是n减去1到i的序列和
if(chen%i==0){
cout<<"["<<chen/i+1<<","<<chen/i+i<<"]"<<endl;
}
}
cout<<endl;
}
return 0;
}
题解:
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: