您的位置:首页 > 产品设计 > UI/UE

HDU-1159 Common Subsequence(动态规划)

2018-02-13 12:44 363 查看
HDU-1159 Common Subsequence(动态规划)

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. Input The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. Output For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. Sample Input
abcfbc         abfcab
programming    contest
abcd           mnp
Sample Output
4
2
0

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    char a[1000],b[1000];
   int dp[1000][1000];
 while(scanf("%s%s",a,b)!=EOF)
 {
     memset(dp,0,sizeof(dp));
   int la=strlen(a);
   int lb=strlen(b);
     for(int i=1;i<=la;i++)  
     for(int j=1;j<=lb;j++)
            {
             if(a[i-1]==b[j-1])            //a是从0开始,而dp是从1开始
             dp[i][j]=dp[i-1][j-1]+1;      //dp表示最大的公共子串
             else
             dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
               }
 printf("%d\n",dp[la][lb]);
}
 return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: