您的位置:首页 > 其它

POJ 2739 Sum of Consecutive Prime Numbers

2018-02-13 10:36 399 查看
Sum of Consecutive Prime Numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions:27231 Accepted: 14695
DescriptionSome positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
Your mission is to write a program that reports the number of representations for the given positive integer.InputThe input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.OutputThe output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.Sample Input2
3
17
41
20
666
12
53
0Sample Output1
1
2
3
0
0
1
2#include<cstdio>
#include<string.h>
using namespace std;
int prim[5002];
bool mp[10004];
void init()
{
int t=0;
memset(mp,0,sizeof(mp));
for(int i=2;i<=10000;i++)
{
if(!mp[i])
{
mp[i]=1;
prim[++t]=i;
for(int j=i+i;j<=10000;j+=i)
mp[j]=1;
}
}
prim[0]=0;
}
int main()
{
init();
int n;
while(~scanf("%d",&n))
{
if(!n)break;
int ans=0,st=1,en=1,sum=0;
while(1)
{
while(prim[en]<=n&&sum<=n)
{
sum+=prim[en++];
if(sum==n)ans++;
}
//if(prim[en-1]>n)break;
sum-=prim[st++];
if(sum==n)ans++;
if(st>en)break;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: