您的位置:首页 > 其它

PAT_A 1024. Palindromic Number (25)

2018-02-12 23:03 281 查看

1024. Palindromic Number (25)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.Input Specification:Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.Output Specification:For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3
不能用整数long long 类型,要用字符串,直接上代码~~import java.util.*;
public class Main {
public static boolean IsPa(String num) {
int len=num.length();
for(int i=0;i<len/2;i++)
if(num.charAt(i)!=num.charAt(len-i-1))
return false;
return true;
}
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner in=new Scanner(System.in);
String num=new String("");
int k;
num=in.next();
k=in.nextInt();
int count=0;
boolean flag=false;
for(int i=0;i<k;i++) {
if(IsPa(num)==true) {
flag=true;
break;
}else {
boolean overflow=false;
String numAdd=new String("");
boolean carry=false;
for(int j=0;j<num.length();j++) {
int dig=(int)(num.charAt(j)-'0')+(int)(num.charAt(num.length()-j-1)-'0')+(carry==true?1:0);
if(dig>=10)
carry=true;
else
carry=false;
if(j==num.length()-1&&carry==true)
overflow=true;
4000

numAdd=(char)('0'+dig%10)+numAdd;
}
if(overflow==true)
numAdd='1'+numAdd;
num=numAdd;
count++;
}
}
System.out.println(num);
if(flag==true)
System.out.println(count);
else
System.out.println(k);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat