您的位置:首页 > 其它

[PAT] 1025. PAT Ranking (25)

2018-02-12 22:02 393 查看

题目

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85


Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4


解析

这道题目输入多个考场的学生学号,分数,然后融合之后排序输出学号、总的排名、考场编号、考场内排名

需要注意几个细节:

- 学号可以用string存储,也可以用
long long
,但是不能用int,会超出存储范围。同时如果用long long,需要考虑到学号起始可能为0,直接存储时会导致前置0的丢失。所以在输出时需要补齐为13位

- 考场编号是从1开始的

- 分数相同的排名相同,如果有排名相同,后面排名就要后移,如1、1、3、4、4、6

代码

#include <iostream>
#include <bits/stdc++.h>

using namespace std;

bool cmp(vector<long long> &v1,vector<long long> &v2){
if(v1[1]!=v2[1]) return v1[1]>v2[1];
else return v1[0]<v2[0];
}

void update(vector<vector<long long>> &v,int nloc){
if(v.empty()) return;
vector<int> rank(nloc,0);
vector<int> lastIndex(nloc,0);
int r=1,s=v[0][1];
v[0][2]=1;
v[0][4]=1;
lastIndex[v[0][3]-1]=0;
rank[v[0][3]-1]=2;
for(int i=1;i<v.size();i++){
r++;
if(s==v[i][1]) v[i][2]=v[i-1][2];
else{
s=v[i][1];
v[i][2]=r;
}
int index=v[i][3]-1;
if(rank[index]==0){
v[i][4]=1;
rank[index]=2;
lastIndex[index]=i;
}
else{
int score=v[lastIndex[index]][1];
if(v[i][1]==score)
v[i][4]=v[lastIndex[index]][4];
else{
v[i][4]=rank[index];
}
lastIndex[index]=i;
rank[index]+=1;
}
}
}

int main()
{
vector<vector<long long>> stu;
int n;
int sum=0;
scanf("%d",&n);
for(int i=0;i<n;i++){
int m;
scanf("%d",&m);
for(int j=0;j<m;j++){
sum+=1;
long long id,score;
cin>>id>>score;
vector<long long> tmp={id,score,0,i+1,0};
stu.push_back(tmp);
}
}
sort(stu.begin(),stu.end(),cmp);
update(stu,n);
cout<<sum<<endl;
for(auto &v:stu){
printf("%013lld %lld %lld %lld\n",v[0],v[2],v[3],v[4]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: