您的位置:首页 > 其它

poj 2386 Lake Counting

2018-02-11 16:54 323 查看
Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40074 Accepted: 19865
DescriptionDue to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.Input* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.Output* Line 1: The number of ponds in Farmer John's field.Sample Input10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.Sample Output3HintOUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.SourceUSACO 2004 November
#include <iostream>
#include <climits>
#include <queue>
#include <set>
#include <map>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <cstdio>
#include <vector>

#define ll long long
#define REP(i, n) for (int i=0;i<n;++i)
#define REP_1(i, n) for (int i=1;i<=n;++i)
#define REP_2(i, j, n, m) REP(i, n) REP(j, m)
#define REP_2_1(i, j, n, m) REP_1(i, n) REP_1(j, m)

#define JU_RAN(a,x,b) a<=x&&x<=b

using namespace std;
const int MAX_N=105;

int m,n;
int dx[8]={0,0,1,-1,1,-1,1,-1};
int dy[8]={1,-1,0,0,1,-1,-1,1};
char field[MAX_N][MAX_N];

void dfs(int x,int y){
field[x][y]='.';

REP(i,8){
int nx=x+dx[i];
int ny=y+dy[i];
if(JU_RAN(1,nx,m)&&JU_RAN(1,ny,n)&&field[nx][ny]=='W')dfs(nx,ny);
}

return;
}

void solve(){

cin>>m>>n;

REP_2_1(i,j,m,n)cin>>field[i][j];

int ans=0;
REP_2_1(i,j,m,n){
if(field[i][j]=='W'){
dfs(i,j);
ans++;
}

}

cout<<ans<<endl;

}

int main() {
std::ios::sync_with_stdio(false);
std::cin.tie(0);

#ifdef LOCAL_DEFINE
freopen("input.txt", "rt", stdin);
#endif

solve();

#ifdef LOCAL_DEFINE
cerr << "\nTime elapsed: " << 1.0 * clock() / CLOCKS_PER_SEC << " s.\n";
#endif
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: