您的位置:首页 > 其它

POJ 2955 Brackets【区间DP】

2018-02-11 12:31 393 查看
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,

if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and

if a and b are regular brackets sequences, then ab is a regular brackets sequence.

no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))

()()()

([]])

)[)(

([][][)

end

Sample Output

6

6

4

0

6

题意:

求括号的最大匹配数.

分析:

不要太拘泥于写法,构造出第i项和第i +1项之间的关系,找到对应的状态方程,再补充细节部分。

当有匹配字符时:dp[i][j]=dp[i+1][j−1]+2;dp[i][j]=dp[i+1][j−1]+2;

暴力区间合并:dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);

i,ji,j分别表示左端和右端,区间转移方程成立,再补充细节部分,即可解决.

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long LL;

const LL mod = 1e8;
const int MAXN = 1e3 + 10;
int dp[MAXN][MAXN];
char str[MAXN];

int main() {
while(scanf("%s", str + 1) && str[1] != 'e') {
memset(dp, 0, sizeof(dp));
int n = strlen(str + 1);
for(int len = 2; len <= n; len++) {
for(int i = 1; i <= n - len + 1; i++) {
int j = i + len - 1;
if(str[i] == '[' && str[j] == ']' || str[i] == '(' && str[j] == ')') {
dp[i][j] = dp[i + 1][j - 1] + 2;
}
for(int k = i; k < j; k++) {
dp[i][j] = max(dp[i][j], dp[i][k] + dp[k + 1][j]);
}
}
}
printf("%d\n", dp[1]
);
}
return 0;
}


有点类似这道题的处理方式:Light OJ 1025

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long LL;

const LL mod = 1e8;
const int MAXN = 1e3 + 10;
int dp[MAXN][MAXN];
char str[MAXN];

int main() {
while(scanf("%s", str + 1) && str[1] != 'e') {
memset(dp, 0, sizeof(dp));
int n = strlen(str + 1);
for(int len = 2; len <= n; len++) {
for(int i = 1; i <= n - len + 1; i++) {
int j = i + len - 1;
for(int k = i + 1; k <= j; ++k) {
if(str[i] == '[' && str[k] == ']' || str[i] == '(' && str[k] == ')')
dp[i][j] = max(dp[i][j], dp[i + 1][k - 1] + dp[k + 1][j] + 2);
else dp[i][j] = max(dp[i][j], dp[i][k - 1] + dp[k][j]);
}
}
}
printf("%d\n", dp[1]
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: