您的位置:首页 > 其它

POJ 3045 Cow Acrobats

2018-02-11 09:58 267 查看
Cow Acrobats
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions:6087 Accepted: 2283
DescriptionFarmer John's N (1 <= N <= 50,000) cows (numbered 1..N) are planning to run away and join the circus. Their hoofed feet prevent them from tightrope walking and swinging from the trapeze (and their last attempt at firing a cow out of a cannon met with a dismal failure). Thus, they have decided to practice performing acrobatic stunts. 

The cows aren't terribly creative and have only come up with one acrobatic stunt: standing on top of each other to form a vertical stack of some height. The cows are trying to figure out the order in which they should arrange themselves ithin this stack. 

Each of the N cows has an associated weight (1 <= W_i <= 10,000) and strength (1 <= S_i <= 1,000,000,000). The risk of a cow collapsing is equal to the combined weight of all cows on top of her (not including her own weight, of course) minus her strength (so that a stronger cow has a lower risk). Your task is to determine an ordering of the cows that minimizes the greatest risk of collapse for any of the cows.Input* Line 1: A single line with the integer N. 

* Lines 2..N+1: Line i+1 describes cow i with two space-separated integers, W_i and S_i. 
Output* Line 1: A single integer, giving the largest risk of all the cows in any optimal ordering that minimizes the risk.Sample Input3
10 3
2 5
3 3Sample Output2HintOUTPUT DETAILS: 

Put the cow with weight 10 on the bottom. She will carry the other two cows, so the risk of her collapsing is 2+3-3=2. The other cows have lower risk of collapsing.
体重最重的应该在最下面,体力最大的也应该在最下面,
因此体力和体重相加,最大的放在最下面。
这里要特别注意,最后求得的值可能是负数,因为可能体力非常大
但是体重都很小。
代码:

#include<cstdio>
#include<algorithm>
using namespace std;
int w[500005];
struct node
{
int w,v,h;
}cow[50005];
bool cmp(const node& a,const node& b)
{
return a.h>b.h;
}
int main()
{
int n,i,j;scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d%d",&cow[i].w,&cow[i].v);
cow[i].h=cow[i].w+cow[i].v;
}
sort(cow+1,cow+n+1,cmp);
w
=cow
.w;w[n+1]=0;
for(i=n-1;i>=1;i--)
w[i]=w[i+1]+cow[i].w;
int mi=-1000000000;
for(i=1;i<=n;i++)
{
mi=max(mi,w[i+1]-cow[i].v);
}
printf("%d\n",mi);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: