您的位置:首页 > 其它

UVA10041 UVALive2202 Vito's Family【中位数+排序】

2018-02-11 07:51 906 查看
The world-known gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living in Lamafia Avenue. Since he will visit all his relatives very often, he is trying to find a house close to them.
  Vito wants to minimize the total distance to all of them and has blackmailed you to write a program that solves his problem.
Input
The input consists of several test cases. The first line contains the number of test cases.
  For each test case you will be given the integer number of relatives r (0 < r < 500) and the street numbers (also integers) s1, s2, . . . , si, . . . , sr where they live (0 < si < 30000 ). Note that several relatives could live in the same street number.
Output
For each test case your program must write the minimal sum of distances from the optimal Vito’s house to each one of his relatives. The distance between two street numbers si and sj is dij = |si − sj |.
Sample Input
2
2 2 4
3 2 4 6
Sample Output
2
4

问题链接UVA10041 UVALive2202 Vito's Family
问题简述:(略)

问题分析

  先计算中位数,再计算最小距离也是一种办法,也需要排序。
  更加简单的计算是排个序,求一下差之和就好了。

程序说明:(略)
题记:(略)

参考链接:(略)

AC的C++语言程序如下:/* UVA10041 UVALive2202 Vito's Family */

#include <bits/stdc++.h>

using namespace std;

const int R = 500;
int s[R];

int main()
{
int t, r;

cin >> t;
while(t--) {
cin >> r;
for(int i=0; i<r; i++)
cin >> s[i];

sort(s, s + r);

int sum = 0;
for(int i=0; i<r/2; i++)
sum += s[r - i - 1] - s[i];

cout << sum << endl;
}

return 0;
}
AC的C++语言程序(中位数)如下:
/* UVA10041 UVALive2202 Vito's Family */

#include <bits/stdc++.h>

using namespace std;

const int R = 500;
int s[R];

int main()
{
int t, r, m;

cin >> t;
while(t--) {
cin >> r;
for(int i=0; i<r; i++)
cin >> s[i];

sort(s, s + r);

m = r % 2 ? s[r / 2] : s[r / 2 - 1] ;

int sum = 0;
for(int i=0; i<r; i++)
sum += abs(s[i] - m);

cout << sum << endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: