您的位置:首页 > 其它

并查集之关系分类 POJ - 1703 Find them, Catch them

2018-02-10 21:50 501 查看

Find them, Catch them

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

D [a]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

[b]Input


The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message “A [a] ” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”

[b]Sample Input


1

5 5

A 1 2

D 1 2

A 1 2

D 2 4

A 1 4

Sample Output

Not sure yet.

In different gangs.

In the same gang.

食物链的简化版

#include<cstdio>
#include<iostream>
using namespace std;
int par[200005];
void init(int n)
{
for(int i=0;i<n;i++)
par[i]=i;
}
int find(int x)
{
if(par[x]==x) return x;
else
return par[x]=find(par[x]);
}
void unit(int x,int y)
{
x=find(x);y=find(y);
if(x==y) return;
else
par[y]=x;

}
int main()
{

int t,m,n;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&m);
getchar();
init(n*2);
char p;int x,y;
for(int i=0;i<m;i++){
scanf("%c %d %d",&p,&x,&y);
getchar();
if(p=='D') {  unit(x,y+n); unit(x+n,y); }
if(p=='A')
{

if(find(x)==find(y))
cout<<"In the same gang."<<endl;
else if(find(x)==find(y+n))
cout<<"In different gangs."<<endl;
else cout<<"Not sure yet."<<endl;
}

}}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: