您的位置:首页 > 其它

1081. Rational Sum (20)

2018-02-10 17:36 246 查看
1081. Rational Sum (20)

时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B

判题程序 Standard 作者 CHEN, Yue

Given N rational numbers in the form “numerator/denominator”, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers “a1/b1 a2/b2 …” where all the numerators and denominators are in the range of “long int”. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form “integer numerator/denominator” where “integer” is the integer part of the sum, “numerator” < “denominator”, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5

2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2

4/3 2/3

Sample Output 2:

2

Sample Input 3:

3

1/3 -1/6 1/8

Sample Output 3:

7/24

注意点:

没有整数部分时,不输出空格

特殊判断:整数部分和小数部分都为0时,要输出0

#define _CRT_SECURE_NO_WARNINGS
#include <unordered_map>
#include <algorithm>
#include <iostream>
#include <iomanip>
#include <cstring>
#include <string>
#include <vector>
#include <stack>
#include <queue>
#include <map>

using namespace std;

typedef struct Rational
{
long int numerator;
long int denominator;
}Rational;

long int gcd(long int a, long int b)
{
if (b == 0)return a;
return gcd(b, a%b);
}

void check(Rational &a)
{
if (a.denominator == 0)
{
a.numerator = 0;
a.denominator = 1;
}
else if (a.denominator < 0)
{
a.numerator = -a.numerator;
a.denominator = -a.denominator;
}
}

void Reduction(Rational &re)
{
check(re);
long int g = gcd(re.numerator, re.denominator);
re.numerator /= g;
re.denominator /= g;
}

Rational Add(Rational a, Rational b)
{
Rational res;
check(a);
check(b);
res.numerator = a.numerator * b.denominator + b.numerator * a.denominator;
res.denominator = a.denominator * b.denominator;
Reduction(res);
return res;
}

int main()
{
#ifdef _DEBUG
freopen("data.txt", "r+", stdin);
#endif // _DEBUG

int n;
Rational sum,tmp;
sum.numerator = 0;
sum.denominator = 1;

scanf("%ld", &n);
while(n--)
{
scanf("%ld/%ld", &tmp.numerator, &tmp.denominator);
sum = Add(sum, tmp);
}

long int s,w;
s = sum.numerator / sum.denominator;
w = abs(sum.numerator) % sum.denominator;
if (s)
printf("%ld", s);
if (s && w)
printf(" ");
if (w)
printf("%ld/%ld", w, sum.denominator);
if (s == 0 && w == 0)
printf("0");

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat甲级 1081