您的位置:首页 > 其它

poj 2236 Wireless Network(基础并查集)

2018-02-10 14:59 483 查看
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 33151 Accepted: 13790
DescriptionAn earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. InputThe first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 1. "O p" (1 <= p <= N), which means repairing computer p. 2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. The input will not exceed 300000 lines. OutputFor each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.Sample Input4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample OutputFAIL
SUCCESS
SourcePOJ Monthly,HQM
[Submit]   [Go Back]   [Status]   [Discuss#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <map>
#define LL long long
#define MAXN 2600;
using namespace std;
struct node
{
int x,y;
}b[1005];
int fa[1005];
int vis[1005];
int n,m;
bool judge(int i,int j)
{
int x1=b[i].x-b[j].x;
int y1=b[i].y-b[j].y;
int d=x1*x1+y1*y1;
if(d<=m*m) return true;
return false;
}
int Find(int x)
{
if(fa[x]==x) return x;
else return fa[x]=Find(fa[x]);
}
void unin(int i,int j)
{
int f1=Find(i);
int f2=Find(j);
if(f1!=f2)
{
fa[f1]=f2;
}
}
int main()
{
ios::sync_with_stdio(false);
cin>>n>>m;
for(int i=1;i<=n;i++)
{
cin>>b[i].x>>b[i].y;
}
for(int i=1;i<=n;i++)
{
fa[i]=i;
}
char c;
int xx,yy;
int cnt=0;
while(cin>>c)
{
if(c=='O')
{
cin>>xx;
vis[cnt++]=xx;
for(int i=0;i<cnt;i++)
{
if(judge(xx,vis[i]))
{
unin(xx,vis[i]);
}
}
}
if(c=='S')
{
cin>>xx>>yy;
if(Find(xx)==Find(yy))
{
cout<<"SUCCESS"<<endl;
}else cout<<"FAIL"<<endl;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: