您的位置:首页 > 产品设计 > UI/UE

UVA1626 Bracketssequence(括号匹配)

2018-02-09 23:31 337 查看
Let us define a regular brackets sequence in the following way: 1. Empty sequence is a regular sequence. 2. If S is a regular sequence, then (S) and [S] are both regular sequences. 3. If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences: (), [], (()), ([]), ()[], ()[()] And all of the following character sequences are not: (, [, ), )(, ([)], ([] Some sequence of characters ‘(’, ‘)’, ‘[’, and ‘]’ is given.
You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1a2 ...an is called a subsequence of the string b1b2 ...bm, if there exist such indices 1 ≤ i1 < i2 < ... < in ≤ m,
that aj = bij for all 1 ≤ j ≤ n. Input The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line
between two consecutive inputs. The input file contains at most 100 brackets (characters ‘(’, ‘)’, ‘[’ and ‘]’) that are situated on a single line without any other characters among them. Output For each test case, the output must follow the description below.
The outputs of two consecutive cases will be separated by a blank line. Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input 1

([(]

Sample Output

()[()]

书上的代码过得,,要是我写肯定写成记忆化搜索.

递推的顺序很重要,要保证小区间都ok了

#include <bits/stdc++.h>
using namespace std;

int T;
char S[10000];
int n;
int d[10000][10000];

bool match(char a, char b)
{
return (a == '(' && b == ')') || (a == '[' && b == ']');
}

void dp()
{
for(int i = 0; i < n; i++)
{
d[i+1][i] = 0;
d[i][i] = 1;
}
for(int i = n-2; i >= 0; i--)
for(int j = i+1; j < n; j++)
{
d[i][j] = n;
if(match(S[i], S[j])) d[i][j] = min(d[i][j], d[i+1][j-1]);
for(int k = i; k < j; k++)
d[i][j] = min(d[i][j], d[i][k] + d[k+1][j]);
}
}

void print(int i, int j)
{
if(i > j) return ;
if(i == j)
{
if(S[i] == '(' || S[i] == ')') printf("()");
else printf("[]");
return;
}
int ans = d[i][j];
if(match(S[i], S[j]) && ans == d[i+1][j-1])
{
printf("%c", S[i]);
print(i+1, j-1);
printf("%c", S[j]);
return;
}
for(int k = i; k < j; k++)
if(ans == d[i][k] + d[k+1][j])
{
print(i, k);
print(k+1, j);
return;
}
}

int main()
{
scanf("%d", &T);
getchar();

while(T--)
{
getchar();
cin.getline(S, 10000, '\n');
n = strlen(S);

dp();

// for(int i = 0; i < n; i++)
// for(int j = 0; j < n; j++)
// printf("%d %d %d\n", i, j, d[i][j]);

print(0, n - 1);
printf("\
4000
n");
if(T)
putchar('\n');
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: