您的位置:首页 > 其它

HDU-1241- Oil Deposits (搜索)

2018-02-09 20:58 423 查看
题目链接---Oil Deposits

                                            Oil Deposits

                                                             Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                             Total Submission(s): 37084    Accepted Submission(s): 21508


[align=left]Problem Description[/align]The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 
[align=left]Input[/align]The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 
[align=left]Output[/align]For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 
[align=left][/align]Sample Input1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0Sample Output0
1
2

[align=left]Source[/align]Mid-Central USA 1997 

题意:求石油田中连通块的个数;
题解:简单的 dfs搜索

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAX 105
using namespace std;
char maps[MAX][MAX];
int dis[MAX][MAX];
int dx[]={1,0,0,-1,-1,1,-1,1};
int dy[]={0,1,-1,0,-1,-1,1,1}; //表示上,下,左,右,左上,左下,右上,右下八个方向
int m,n;
void DFS(int x,int y)
{
dis[x][y]=1;
for(int i=0;i<8;i++)
{
int xx=x+dx[i];
int yy=y+dy[i];
if(xx>=0&&xx<m&&yy>=0&&yy<n&&!dis[xx][yy]&&maps[xx][yy]=='@')
{
DFS(xx,yy);
}
}
}
int main()
{
while(cin>>m>>n,m,n)
{
memset(dis,0,sizeof(dis));
int ans=0;
for(int i=0;i<m;i++)
{
cin>>maps[i];
}
for(int i=0;i<m;i++)
{
for(int j=0;j<n;j++)
{
if(maps[i][j]=='@'&&!dis[i][j])
{
ans++;
DFS(i,j);
}
}
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: