您的位置:首页 > 其它

*寒假水19——Rectangles (矩形重叠求重叠面积)

2018-02-09 20:00 344 查看
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .InputInput The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).OutputOutput For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
Sample Output
1.00
56.25

#include<stdio.h>

double max(double a,double b);
double min(double m,double n);

int main()
{
double x1,y1,x2,y2,x3,y3,x4,y4,x,y,tmp;
while(scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4)!=EOF)
{
if(x1>x2) tmp=x1,x1=x2,x2=tmp;
if(x3>x4) tmp=x3,x3=x4,x4=tmp;
x=min(x2,x4)-max(x1,x3);
if(y1>y2) tmp=y1,y1=y2,y2=tmp;
if(y3>y4) tmp=y3,y3=y4,y4=tmp;
y=min(y2,y4)-max(y1,y3);
printf("%.2lf\n",x<0||y<0?0:x*y);
}
return 0;
}

double max(double a,double b)
{
if(a>b) return a;
else return b;
}

double min(double m,double n)
{
if(m>n) return n;
else return m;
}
题解:暴力算就好。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: