您的位置:首页 > 其它

POJ 2456 Aggressive cows(二分,最大化最小值)

2018-02-09 16:51 375 查看
Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions:17674 Accepted: 8425
DescriptionFarmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?Input* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xiOutput* Line 1: One integer: the largest minimum distanceSample Input5 3
1
2
8
4
9Sample Output3HintOUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.
#include<cstdio>
#include<algorithm>
using namespace std;
int id[100004];
int main()
{
int n,c;scanf("%d%d",&n,&c);
for(int i=0;i<n;i++)
scanf("%d",&id[i]);
sort(id,id+n);
int q=0,r=1e9+1;
while(r-q>1)
{
int mid=(r+q)/2;
int ans=1,dec=id[0];
for(int i=1;i<n;i++)
{
if(id[i]-dec>=mid)
{
ans++;
dec=id[i];
}
}
if(ans>=c) q=mid;
else r=mid;
}
printf("%d\n",q);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: