您的位置:首页 > 其它

HDU-1312-Red and Black(搜索)

2018-02-08 23:30 507 查看
题目链接---HDU-Red and Black
             
               Red and BlackTime Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64uSubmit StatusDescriptionThere is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
InputThe input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 
OutputFor each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13

题意:房间里(图中的矩阵)有红砖和黑砖,黑砖即' . '能踩,红砖' # '不能踩,初始位置在'@'位置,只能上下左右行走,遍历整张图求所踩的最大的砖数
题解:这道题是一道典型的搜索题,下面我用的是bfs解决的这道题
代码实现如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAX 25
#define INF 0x3f3f3f3f
#include<queue>
using namespace std;
typedef pair<int,int>P;
char maps[MAX][MAX];
int dis[MAX][MAX];
int dx[]={1,0,0,-1};//表示方向
int dy[]={0,1,-1,0};
char sx,sy;//表示开始坐标
int m,n;
queue<P>que;
int bfs()
{
for(int i=0;i<m;i++)
{
for(int j=0;j<n;j++)
{
dis[i][j]=INF;
}
}
que.push(P(sx,sy));
dis[sx][sy]=0;
int k=1;//记录所走的砖数
while(que.size())
{
P s=que.front();
que.pop();
for(int i=0;i<4;i++)
{
int nx=s.first+dx[i];
int ny=s.second+dy[i];
if(nx>=0&&nx<m&&ny>=0&&ny<n&&dis[nx][ny]==INF&&maps[nx][ny]=='.')
{
que.push(P(nx,ny));
dis[nx][ny]=dis[s.first][s.second]+1;
k++;
}
}
}
return k;
}
int main()
{
while(cin>>n>>m)
{
if(n==0&&m==0) break;
for(int i=0;i<m;i++)
{
cin>>maps[i];
}
for(int i=0;i<m;i++)
{
for(int j=0;j<n;j++)
{
if(maps[i][j]=='@')
{
sx=i;
sy=j;
}
}
}
int ans=bfs();
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: